You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
Guy Sartorelli cb02df3e4a
Merge pull request #687 from creative-commoners/pulls/3/review-behat-tests
2 weeks ago
.github/workflows MNT Add github action for deploying userdocs 1 month ago
.tx Revert "Removing translations in preparation for namepsacing them" 5 years ago
_config Merge branch '3.2' into 3.3 2 years ago
client Upgradeing dependencies 3 years ago
docs DOC Very minor doc tweak to test netlify hook 3 weeks ago
lang Update translations 5 months ago
src ENH PHP 8.1 compatibility 5 months ago
templates Fix category and tag buttons using input groups from bootstrap 2 years ago
tests ENH Replace ADMIN permissions with less permissions in Behat test 2 weeks ago
.editorconfig Update readme, editorconfig, phpcs ruleset 5 years ago
.eslintignore Upgradeing dependencies 3 years ago
.eslintrc.js API Convert gulp and Compass builds to use Webpack 5 years ago
.gitattributes Update readme, editorconfig, phpcs ruleset 5 years ago
.gitignore API Convert gulp and Compass builds to use Webpack 5 years ago
.nvmrc Upgradeing dependencies 3 years ago
.sass-lint.yml API Convert gulp and Compass builds to use Webpack 5 years ago
.upgrade.yml update namespace for blog controllers 4 years ago
README.md MNT Standardise modules 2 months ago
_config.php FIX refactored to remove code from _config.php 5 years ago
behat.yml MNT Add behat tests 11 months ago
changelog.md Update changelog for 2.4.2 6 years ago
code-of-conduct.md Added standard code of conduct 7 years ago
composer.json Merge branch '3.9' into 3.10 2 months ago
license.md Update license year 5 years ago
package.json MNT Travis shared config, use sminnee/phpunit 2 years ago
phpcs.xml.dist MNT Travis shared config, use sminnee/phpunit 2 years ago
phpunit.xml.dist MNT Standardise modules 2 months ago
webpack.config.js API Convert gulp and Compass builds to use Webpack 5 years ago
yarn.lock Merge pull request #673 from silverstripe/pulls/3/update-js-1648772547 4 months ago

README.md

Silverstripe Blog Module

CI Silverstripe supported module

Documentation

Requirements

  • Silverstripe CMS 4.0+
  • Silverstripe Lumberjack Module 2.0+
  • Silverstripe Tag Field Module 2.0+
  • Silverstripe Assets 1.0+
  • Silverstripe Asset Admin Module 1.0+

Note: this version is compatible with Silverstripe 4. For Silverstripe 3, please see the 2.x release line.

Suggested Modules

  • Silverstripe Widgets Module
  • Silverstripe Comments Module

Installation

composer require silverstripe/blog

Upgrading

Upgrading from 2.x to 3.x

Aside from the framework and CMS upgrades required the blog module should not require anything extra to be completed.

Upgrading legacy blog to 2.x

If you're upgrading from blog version 1.0 to 2.x you will need to run the BlogMigrationTask. Run the task using dev/tasks/BlogMigrationTask either via the browser or sake CLI to migrate your legacy blog to the new version data structure.