You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
Steve Boyd a88bd6fff6 Merge branch '3.8' into 3 2 months ago
.github/workflows Merge branch '3.8' into 3 2 months ago
.tx Updated translations 7 years ago
_config Add legacy YAML for upgrading 3 years ago
client ENH Use yarn and webpack to upgrade jquery 2 years ago
css Restore empty comments.css file 3 years ago
docs/en Update Installing.md 3 years ago
lang ENH Update translations 2 years ago
src fix: field formatting to correct include link 4 months ago
templates Upgrade dependencies and build settings 3 years ago
tests Merge branch '3.7' into 3.8 2 months ago
.editorconfig Upgrade dependencies and build settings 3 years ago
.eslintignore Upgrade dependencies and build settings 3 years ago
.eslintrc.js Upgrade dependencies and build settings 3 years ago
.gitattributes NEW Convert to vendor module, add table_name to test stubs and add PHP 7.2 to travis 5 years ago
.gitignore Add phpunit, lint fixes and removed compass for webpack 5 years ago
.nvmrc Upgrade dependencies and build settings 3 years ago
.upgrade.yml Remove deprecated@2.0. Update Migrate task to check table name. Minor tweaks to class names. Use Director::absoluteURL. 6 years ago
README.md MNT Standardise modules 2 months ago
_config.php FIX Merge config in tests, add phpcs and add HTML purifier to Travis builds 5 years ago
code-of-conduct.md Added standard code of conduct 7 years ago
composer.json Merge branch '3.7' into 3.8 2 months ago
license.md Updated license year 7 years ago
package.json DEP Update JS dependencies 10 months ago
phpcs.xml.dist MNT Travis shared config, use sminnee/phpunit 2 years ago
phpunit.xml.dist MNT Standardise modules 2 months ago
webpack.config.js ENH Use yarn and webpack to upgrade jquery 2 years ago
yarn.lock Merge pull request #337 from silverstripe/pulls/3/update-js-1648772023 4 months ago

README.md

Comments

CI Silverstripe supported module

Introduction

This module provides commenting functionality for Pages and other DataObjects on your Silverstripe site.

For more documentation about the module see the provided documentation located inside the docs folder.

Requirements

  • Silverstripe ^4.0

Note: This branch is compatible with Silverstripe 4. For a Silverstripe 3 release, please see the 2.x release line.

Installation

composer require silverstripe/comments

See docs/en/Installing.md

Contributing

Translations

Translations of the natural language strings are managed through a third party translation interface, transifex.com. Newly added strings will be periodically uploaded there for translation, and any new translations will be merged back to the project source code.

Please use https://www.transifex.com/projects/p/silverstripe-comments/ to contribute translations, rather than sending pull requests with YAML files.

See the "i18n" topic on doc.silverstripe.org for more details.